NO BUG: Pagination doesn't work

Browser: Chrome last version
OS: macOS last version.
URL: Réalisations-cpt Archive - Noctaupus

I’ve create a template to display my projects (using CPT).

The template conditions are set for the correct CPT (displaying good contents in editor) + set to “individual” with “realisations” pages selected below.

“realisations” page is empty to catch the template contents + the pagination.

The pagination isn’t working anymore it makes the 404 appear instead.

Thanks a lot

Hi @noctaupus,

I’m not sure I 100% understand your setup so could you please email us at with the same email you used to purchase Bricks and a link to this thread so I can take a look :slight_smile:

Thank you.

I try to explain better
Pagination doesn’t work into a template.

In front, I have a 404 error page when I navigate to another page from the pagination. I refresh permalink, same result.

Since I make change in CPT it doesn’t work anymore (I believed).
This template is set to display archive of the new CPT “réalisations-cpt”.

In bricks editor, on pagination element.
When “main query” is selected pagination appears, when “Projets loop” is selected pagination vanish.

I believe I understand where the problem come from.
It seems Metabox “custom rewrite slug” doesn’t work with bricks pagination.

1 Like

Same issue for me. Tried different stuff.
Actually the pagination works when in wooCommerce settings the used page for displaying products is not set as ShopPage

Hi @noctaupus,

Sorry missed your reply. But yes you’re correct, if you’re rewriting slugs then the rewrite rules in WordPress are. So this is more of a WordPress “limitation/issue” and should practically happen with any theme.

@dev.zomerfeld do you also have a plugin or custom code that rewrites slugs? if not please feel free to create a new bug report with details on how to reproduce the issue :slight_smile: