NO BUG: Menu Builder Nested

Browser: Safari/Firefox
OS: macOS
URL: (Local Development)
I have a problem with the Menu Builder (Nested).
When I display the menu in reponsive mode, all menu links (main level) are still displayed + the mobile icon (burger). I have a dropdown in this menu which opens a megamenu. How can I hide the normal links so that only the “burger” is visible in the mobile ? (Enclosed two pictures). Thanks and regards


Hi Ivo,
Thanks so much for your report!

Would you be so kind as to provide a live link, so I can inspect your styles?
Unfortunately I can’t say anything about it without a link…

Best regards,

Hi Timms,
the Problem seems solved (seems a caching issue). But I have another Problem:
I’m using the nestle Menu Element - if I test the Mobile View - the Links randomly not clickable. Same Structure as in Pictures above. When the First Link (it’s a Megamenu Link) is clicked the following Links are clickable or not. It appears complete randomly. I have tried to clear the cache but doesn’t help.
Best, Ivo

okay, after some tries - this Problem seems only on Safari but also on iPhone direkt.

Hi Ivo,
I’m glad that the problem has fixed itself.

The other problem with the mobile menu is probably due to the ::before pseudo elements and will be fixed in the next version (1.9.4).

Hi Timmse,
Is there an approximate date for the fix? I would have to decide if I can use Bricks for the current project or if I have to go to Oxygen (which I didn’t really want) :wink:

I have been able to define the problem a little more precisely:
If you go in the mobile menu from TOP to bottom over the links - the first hover works - 2 and 3 do not work.
If you come with the mouse from below (from the last menu item) - and go up over all three menu items - all hover work

1.9.4 will probably/hopefully be released before you finish a completely new project (without knowing the project details) :smiley:

Yeah, I’m pretty sure that’s the :pseudo element issue that will be solved in 1.9.4 :+1:

Okay - meanwhile i will concentrate to the other Stuff :ok_hand:

Hey Louie,
How much progress have you made with your project :smiley: ?

The problem should be fixed in Bricks 1.9.4:

1 Like

I have a dropdown link set to toggle on hover (default), but sometimes the text part was not clickable in Chrome dev tools in Windows 11.

v1.9.4 fixes it.

Hey Timmse,
PERFECT ! Now it works. Best Thanks to the Team for the great Support and Work!