NO BUG: ACF dynamic data not pulling from loop

I’m having the same issue listed here when using bricks builder and Advanced Custom Fields: SOLVED: Dynamic data calls to ACF relationship field no longer works - #24 by timmse

I’m creating a single post template in bricks for a custom post type and am trying to list custom posts related to my CPT as well. I’ve set up a bidirectional relationship between the two custom post types. I’m trying to display all of the related custom post type B posts on the Single page for custom post type A. I watched a video about this from WPTuts but it doesn’t seem to be working for me for some reason.

I set up a loop on the parent container that points to the relationship between the two but when I try to add custom fields from the related post type to the page they don’t populate on the front or backend. Everything is setup correctly as far as I know. I tried most of what was in this thread except for the loop within a loop thing which I didn’t understand how to do. Any insight or suggestions are greatly appreciated!

Hi Selly,
Thanks for your report and the login credentials!

You have wrapped your relationship loop with your relationship loop again for unknown reasons so that no results can be output. A “simple” loop is sufficient here.

I have assigned the two available awards to the “50 Years of Hip Hop” podcast post and removed the double loop, and as far as I can see, it works as expected.

Thanks for your help with this. I don’t know what you mean by double loop? This looks exactly like how I had it set up as far as I can tell. Can you detail what I did wrong? I’m don’t see a double query loop in my template?

By double loop, I mean the same relationship loop within itself, which can’t work.

This was your setup:

Ah, I see. Didn’t realize I’d done that. Thanks for clarifying!