Bricks now with Unlimited Sites & Upcoming Lifetime Price Increase

How to exclude Mobile Menu Toggle from caching?

Hey @timmse (or any other CSS / Cache / LiteSpeed gurus).

Hope you can come to the rescue on this. My mobile menu toggle is not working which i believe is down to caching.

I have options to either exclude the CSS as its main file or as a the CSS (not HTML) selector as highlihted in the image below.

Here is what i have currently excluded (this animate.min.css was for another issues) and UCSS whitelist was what i thought was the selector but it does not work.

Any idea?

Website is https://www.wdsaigon.com

Update just trying this

.bricks-element-nav-menu .bricks-mobile-menu-toggle {
bottom: 0;
content: “”;
left: 0;
position: absolute;
right: 0;
top: 0;
z-index: 1;
}

Thank you!

Hi Michael,
when i visit the site now it works like a charm :star_struck:
Problem solved?

Hey Stefan,

I dont think so unfortunately - I thought the same but once the cache regenerated, it wasn’t working again. Im guessing you might have hit (missed) an uncached version too. :tired_face:

If you refresh the page after going to it, it should be cached.

No problem in Chrome after visiting xx times, but in safari after the second visit.
Are you really sure that this is a css related issue? When you disable the css cache it is working (every time)? :face_with_monocle:

Hey stefan

Yes, just deactivated LS cache plugin, CDN and cloudflare proxy and it is now working.

Is the toggle a CSS or JS element or even both to activate the mobile menu? Do you know file it belongs to?

Kind Regards

Mick

Ok, but disabling the whole plugin won’t lead you to the root of the problem :smiley:

First, we need to figure out if it is a CSS or JS problem: CSS/JS Issues | Troubleshooting | LSCache for WordPress | LiteSpeed Documentation

The toggle button itself is styled by CSS (and the styling looks good even when cached), the mobile menu functionality is JS. Since the button is not clickable, I rather guess a JS problem, but you will only be able to find out if you follow the instructions in the link.

I agree, but i wanted to discount the possibilty of it not being a caching issue. :stuck_out_tongue_winking_eye:

Yes, I followed that for other breakages on the site and excluded them, but did not know what js file or cs file was responsible for it if you knew from the top of your head.

I saved all the files from the previous debugging so will just run them again.

Cheers bud :slight_smile:

The only possible js file that causes the issue is “bricks.min.js” :wink:
Btw., not related to the problem: https://www.wdsaigon.com/wp-content/uploads/2021/04/plane2-ABJXX39-3-1200x492.png is missing on your homepage :smiley:

Haha yes!! it is a ghost image. I cannot for the life of me find it!

I have sent a video and some bugs that Luis is looking at. Fingers crossed his ghost hunting skills are better than mine haha.

Im pretty sure i excluded that file…but I will go at it again #hatecachingissues haha