Force Bricks Editor

Hello,
This is my first post. I apologize if this is not the correct category.

As with most websites, the biggest impact to design and content integrity comes when the client starts maintaining their own copy/content. Even when trained, those who are not technically inclined or savvy with WordPress / CMSs, will eventually have issues. Additionally, this client is an organization that is likely to have multiple different users accessing and updating content. I am trying to mitigate confusion and design degradation by limiting the choices available to any non-admin user.

Specifically, I’m wondering if there is a way through Bricks (or a WordPress plugin if you know of any) to limit all content editing to the Bricks editor? Basically, I want to disable Classic AND Gutenberg editor.

My concern is this, even when I create User’s Manual that instructs the client to only edit content by clicking the “edit with Bricks” link in the dashboard, they are going to be inclined to click the page title, thus engaging the classic editor (I have disabled Gutenberg). Once they engage the classic editor, one of two things will occur:

  1. When they engage the Classic editor, they will see no content because the page will have been built in Bricks. They will become distraught and/or confused and reach out for support.
  2. Or they will add and save content in the Classic editor, thus enabling the WordPress content instead of the Bricks content.

I don’t think there is a way to do what I am asking, but I thought I’d reach out to the community to be certain.

Thanks in advance for your thoughts.

you cant disable it.
but you can hide the edit buttons with css for classic or block editor.

hook a CSS to both frontend for admin bar and backend for edit buttons.
you just need to select those links and display:none it

1 Like
function remove_post_content_field() {
    remove_post_type_support('post', 'editor');
    remove_post_type_support('page', 'editor');
}
add_action('init', 'remove_post_content_field');

@sinanisler, That’s an option I neglected to explore. Thanks. The only issue being that the Title in the dashboard (I think) only links to the classic or gutenberg editor. Thanks again!

@clickfusion63,
Thanks much for that solution. I’ll give it a spin.

for hide link

function hide_edit_post_link() {
    global $post;
    if (is_singular() && current_user_can('edit_post', $post->ID)) {
        echo '<style>#wp-admin-bar-edit { display: none; }</style>';
    }
}
add_action('wp_head', 'hide_edit_post_link');
1 Like

How are you editing meta boxes from other plugins (e.g. SEO plugins) if you disable the post edit links?

Good point, @Allucinante. I think the first solution provided by @clickfusion63 is probably the best bang for the buck. It simply removes the text editor while still presenting the rest of the editor interface fields. The only thing I would want to do differently would be to add a message where the text editor was instructing the user to engage the Bricks builder. I’m researching that now…

add_action('edit_form_after_title', 'add_edit_link');

function add_edit_link() {
    global $post;
        echo '<style>
            .ed-bricks {
              background: #ffd64f;
              color: #000;
              padding: 20px;
              display: inline-block;
              margin-top: 10px;
            }
          </style>';
    echo '<a class="ed-bricks" href="'.get_permalink($post->ID).  '?bricks=run'.  '">EDIT IN BRICKS</a>';
}

Hi all,

I had a similar problem, although not the same.

I have a site, where some pages are edited with Bricks and some with Classic Editor (and subsequently rendered by Bricks template). My clients were totally confused which pages are made by Bricks and which by WP and which type of editor to use. They kept using the wrong editor and thought the page updates are not working. They also tend to switch the rendering between both editors.

So I made a little JS tweak to switch to Bricks tab in the Classic Editor by default, when the page is made with Bricks. The whole topic is here: Buggy behaviour in Classic Editor view

Maybe it can help someone else with the same problem. Or maybe someone here can come up with a better solution. Nevertheless, I find the current solution in Bricks a bit confusing.