Create author archive page?

I’m definitely having a mental blockage somewhere.

I am creating a very simple directory of wordpress users. I have extra fields set up through Metabox. All good so far.

I have created a loop that shows “cards” for each member. I want website visitors to be able to click on the card and find out more about that member.

I’ve looked around this forum and found a few ideas but nothing seems to work. As far as I understand it, the actual URL I need to get to is…

mydomain.com/author/userid

I have found {author_name:link} and have tried setting it up as an external URL link but that doesn’t get me to the end point either.

Can anybody help?

Just done a bit more digging and according to the bricks academy the only author fields you have available are…

{author_name} – Returns the post author name {author_bio} – Returns the post-author biographical info
{author_email} – Returns the post author email {author_website} – Returns the post author website
{author_avatar}` – Returns the post author avatar as an image tag (text) or an image url (link)

I can’t use any of those to get to the author link I need, it needs an additional… {author_username}

Everything works
Screenshot_19


You can display everything related to the user/author

You misunderstand my problem.

I need to be able to get the link to the author archive from inside a query loop.

The problem is not displaying data on the author archive template. That works fine.

Do you need to get a list of the author’s posts or get a link to the author’s page?

I need to get a link to the author’s page.

So, you need to get on the page of the post a link to the page of the author of this post, right?

I have a page showing member cards in a query loop.

I need to link, from that member card, to the author’s page on the website.

The actual link is mydomain.com/author/xxx

Where “xxx” seems to be the WP username of the author.

The “xxx” is the bit I cannot get my hands on.

One more question. These cards are profiles of users who registered themselves?

upload this template here

Just curious. Did you get this solved?
I am in the same boat…