Button with dynamic data

I have a button that i want to display and use dynamic data to it.
So, using ACF i set a group field called “Button1”, with two fields in it, “Title1” for the title of the button and “Link1” for the link of the button.
Then i create a button in Bricks with the corresponding dynamic fields and… It doesn’t work.
What is wrong with the way i implement this ?

1 Like

Try enabling the query loop for the container which contains the button.

Enabling the Query Loop:

Setting for the button:

If you have many posts in CPT, please set 1 to post per page.
This is how I do it.

Hope it helps.

this is how i try to do it, but it doesn’t work

I don’t have it in a container, but it is supposed to not be needed.

Yes. It’s not necessary to add a new container for just a button. Btw, you can try enabling the loop query for this container(highlighted) and set your query to see if it works.

But the screenshot i have sent you is not working.

As a result i get an empty button with no text on it, and no link on it as well.

I can see you have set dynamic data. Have you tried enabling the loop query for that container(highlighted)? In the screenshot, I can see it is not.

I have the same situation when the loop builder is not enabled.

But there is no loop involved here.

1 Like

What is Link 1…? Shouldn’t your acf field name should be there and at the top should be button name? Check below screenshot. It works fine for me.

Because you have ACF item. That’s why I suggested so.

I have the following Custom Field.
It is a group with a text field that is intended for the button text (named “Τιτλος 1”) and a url field for the button link (named “Link 1”).
I try to set the text and the link of the button dynamically but it is not working.

I tested with the same. It’s working fine for me.

My fields:

Single Post Content:

Bricks Single Post Template:


1 Like

What the hell am i doing wrong?
Might it be the Greek labels of the ACF fields ?

Not sure. I don’t think the labels will cause the issue as they use the name to fetch the field data. Are you on the latest version of Bricks ( & ACF? If yes then you should send access to Bricks support to check.

Bricks and ACF Pro latest.
Deleted the group in acf and created a new one with the same structure in English.

I tried to only enter the button label fron the ACF group and still empty button.
I believe i am missing something, but i don’t understand what…

Try with button outside of any container. Also delete and create a new button.

I have tried it in a new page… not working… so strange !!!

How can i get more help ?

Email bricks support.

I just remember I was running ACF 6.0 alpha 2 on this test site. You may wanna try that.ACF might have fixed some bug. Introducing the ACF PRO Block Versioning Developer Preview · Issue #654 · AdvancedCustomFields/acf (github.com)

Its hard for me to install an alpha version of the ACF, since this is a production site.
Any more ideas ?