Bricks now with Unlimited Sites & Upcoming Lifetime Price Increase

WIP: Single product Product Gallery Lightbox

Light box error in customizing a single product template. Am I set incorrectly?

Default normal display

Hi dichen,

it seems that your topbar (Free standard shipping…) has a higher z-index as the lightbox. Try to decrease the z-index of your topbar :slight_smile:

Providing a live link would be helpful as well… screenshots are always like playing hide and seek in the dark :smiley:

Best regards,
timmse

https://try.bricksbuilder.io/tade6e4d/product/test/

Thank you very much for the link!
You did nothing wrong, there is a z-index issue with the product gallery element :bug:

I will add it to our bug tracker to get it fixed soon.

Best regards,
timmse

Another problem is that when I set to disable the light box of the product library, I can still click the product picture, which is the URL address of the picture directly opened on the current page.

Where can you disable the Lightbox?

Bricks > Settings > WooCommerce > Single Product > Disable Product Gallery Lightbox

Hello Dichen,
thank you so much for the tip :blush:

As I mentioned in another thread, I’m not that deep into Bricks + woocommerce yet, but learn every day through hints like yours :raised_hands:t2::smiley:

When you leave the zoom enabled, you cannot click the image. You can still hover, but not click it.
To completely disable the click and zoom fcuntionality, add this line to your custom css:

.woocommerce-product-gallery__image {
  pointer-events: none;
}

Best regards,
timmse

1 Like