Bricks now with Unlimited Sites & Upcoming Lifetime Price Increase

WIP: Incorrect button text ("I am a button") displaying on the front-end after upgrading from 1.3.4 to 1.3.6

Bricks Version: 1.3.6
Browser: Chrome
OS: Windows 11
URL: (localhost only)

Hi guys. I’m back to my main test site for Bricks, hurray, but on installing 1.3.6 from 1.3.4 I can see several wapping (and strange) errors connected to global elements (created in 1.3.4 or earlier).

The first is that several of my global buttons display perfectly (IE correct text) in the backend but render with the wrong button text in the frontend. So what I have in the backEND, for example, is ‘Get A Quote’ and the front end Bricks is outputting ‘I am a button’. I have the same error on several of my global buttons but not all of them.

I have another global ‘Rich Text’ element that has the target text in the backend but in the frontend it’s displaying your placeholder text “Here goes your text … Select any part of your text to… etc” and I have a very similar issue with a my global accordions which are also displaying placeholders (“Accordion title” and “I am a so called subtitle”) in the front end whereas each global accordion has the correct title and text in the backend.

What gives? Is there an upgrade process I need to go through first? I am hoping, of course, that there is a fix as I really don’t want to go through each global occurence to edit manually again - as I did circa 1.3.3 to fix a different globals issue. Pretty please. Love the look of the other updates but can’t move on to those until I know this is a fixable temporary glitch - if you wouldn’t mind confirming.

Many thanks guys.

Team Bricks; you fine folks, can I get a comment on these please. Is this a known bug? Is there a fix? It’s been 48hrs now. New details below as now I’ve tested further I can see there seems to a consistent but random aspect to which global elements don’t display in the front end.

Fellows designers/devs:
Are you using global elements yet? It’s a great feature, I love them, but to date they’ve seemed buggy. If you don’t know what a global element is: drag any bricks element into the builder, update the content, right-click and save ‘save as global element’, then rename the element to help identify it. Once created you can hot-wire it (live update the element on the page) and you update all element occurrences across the site). If you have been using them have you not seen this bug?

New details (after testing further)
As a guide (and as outlined above) I’m making quite extensive use of global elements as I think they’re great. Clients love them too. In particular my main test site uses three global elements in every header (bricks header templates) and the site uses multiple header templates, as you do, but each header template uses the same three global elements (which is your newly created ‘Rich Text’ element, now converted from the previous ‘Text’ element as existed in bricks 1.3.4 (and earlier)) but what I’ve found is that all of these globals sometimes display fine (and always display fine) but only on certain Headers. For example, I have a “24hr Shipping” Rich Text global that always displays fine on one header (in the frontend) but never displays properly (the content isn’t shown) on another and I have others that only appears on one header. Likewise, I have another header that never displays the content any of the globals, baring in mind these are are the same globals. So that’s a strange front-end bug. All of these globals contain the correct content in the backend, which can be edited and saved but doing so makes no difference to their displaying in the frontend.

The bug is not restricted to the Rich Text globals either, and although I would need to check this further, as far as I can see all my Accordion, Button and Rich Text globals all have the same missing frontend content.

Team bricks: it would be good to know if this is a known bug and what the fix is, of course, as mentioned 48hrs ago, tut tut. I know you’re busy whipping up great new features (hopefully including that new custom loop builder and WooCommerce phase 2) but I can’t continue with the current build until I know what the fix is for this one (and don’t tell me I need to delete all the globals again and replace them all)! :smile:

Many thanks.

Q.

Hi Colin,

sorry for the “late” reply and your inconvenience.

So far, we had no reports of this behavior (except yours), which means we had to try to recreate it. And that’s what we’ve done in the last 48h hours (besides new features and other bug fixes for Bricks 1.3.7).

However, I can confirm the issue and have added it to our bug tracker. When and how we will be able to solve the problem, I, unfortunately, can’t say at this point. As soon as I know something new, I will let you know.

In the meantime… How many global elements do you currently have on your site and how long would it take to actually replace them manually so you can proceed?

Best regards,
timmse

Thanks Timmse. Good to know you’re looking at it.

To date we have twenty globals (buttons, accordions and rich text) but many more repeat embedded occurrences, c. 60-100 of them (ballpark) which is why it would be rather galling to have to update one by one (after recreating) which is what we’ve already had to do once already c. bricks 1.3.2-4. I guess that it might take half a day or so recreate/update them manually - unless this turns out to be compound bug (IE not residing 100% within the global itself but related to other elements on the page, template, build)?

PS I was trying to encourage others to feedback on this as I imagine the use of the global elements isn’t widely known/understood yet - but it’s a great feature that Luis put me onto that I’d missed in the tutorials.

Hi,

I think there is a good chance to get this solved without doing it manually because the global text is still available on the canvas (which is pretty strange, though) - but don’t nail me down on that :roll_eyes:

Yes absolutely, your commitment is awesome! We are currently working on the expansion of Bricks Academy and will definitely go more into global elements (all elements in general) as well.

Thanks Timmse. My feeling, for what it’s worth, is that there is something else lurking around there. At some point, for instance, I accidently added some characters directly into the in-page builder (as opposed to in the text editor) and characters didn’t appear in text editor view at all even when I toggled between text and visual builder (which usually reloads text updates into the visual editor, or vice versa) but the characters never appeared there and instead persisted only in the in-page builder WYSIWYG view - then they disappeared again before I could save it/do anything else. I have no idea if that might help you but it seemed a related odd behaviour.