WIP: Counter element problem

Bricks Version: 1.4RC
Browser: Firefox Developer Edition 100.0b9
OS: Windows 10
URL: local site using LocalWP

I created a local copy of website from 1.3.6 and upgraded it to 1.4RC. I created short video to demonstrate my issue. (Bubbles - Collaborate In-Context)
And there is another problem, which is not shown on the video, that duration is not 3000ms but much longer.
To sum up:

  • If the difference between Count from and Count to is too high, the number gets messed up and it does not even animate
  • The animation duration doesn’t work, it is way too long.

If you need any more info, I am happy to provide it. But the site is local and not online, so I can not give you the URL.

Regards,
Matej

Hey Matej,
Thank you very much for your report!

I was able to reproduce the issue and added it to our bug tracker.

Best regards,
timmse

1 Like

Hi,
I upgraded my site to RC2 and it seems like the problem is partly solved. Now, the number doesn’t get messed anymore, but the timer still doesn’t work properly. For me, it looks like it is always the same speed and it doesn’t matter what is the animation in ms set on element.

Best regards,
Matej

Hi Matej,
thanks for getting back!

Did you check the frontend as well? As far as I can see, it works properly on the frontend… so we’re at least at 75% fixed :grin:

Best regards,
timmse

Hi.
Hm, I still don’t think it works, at least for me. :sweat_smile: I don’t think it matters, but I’m running this on local computer (Local WP). Video: Bubbles - Collaborate In-Context

I did even try with only one counter on page, but no success. :’(

Best regards,
Matej.

I can’t read the settings (is there a way to view the video in fullscreen mode?), but the from and to values are completely different…

So I tried it again using same values (1000) but different animation times, to make the counters comparable: https://vimeo.com/709615622/414c4e9251

Hi, thank you for your time and your screen recording. Sorry that you can’t read values, I recorded another video, using different software and on smaller screen, so I hope it is better.

You will see in the video that I have 3 rows with 4 columns.

  • First row is just to show for how many seconds countdown is set in column (1s, 2s, 5s, 10s)
  • Second row counts from 0 to 1000
  • Third row counts from 0 to 10000

Here is the video, where I didn’t use timer, as you did, but I think is pretty obvious that something is off. I also stopped recording before last element finished updating as it would take too much time :wink:

What I can try next week is to create completely new site using 1.4RC2 and I will see it the same will happen then.

Btw, should counting from higher number to smaller work? Because it does not work for me, or this is not supported?

Thanks,
Matej

Hi Matej,
short info: we have found the bug, will be fixed in the next version! :v:

1 Like