WIP: Copy styles does not integrate attached css classes

Bricks Version: 1.3.6
Browser: Chrome 90
OS: Windows 10

When I use the “copy style” in the builder for an element (basic text, richt-text, etc.), the css-class(es) attached to the source element will not be copied AND could not be pasted via “paste style”.

Hey @joachim.auster Welcome to the forum :muscle: :+1:

It’s not a bug as it is not a feature yet, but the good news one if the team has said it will be coming in one of the next couple of releases. It might even make it to 1.3.7 perhaps. who know :grinning:

Here is the thread that had the information on so you can read too:

Hey @Michael,
good to know, or not :wink:

I am an Oxigen user where copying styles also copies the attached classes.
I did combine the container styles topic with my one.

Thanx for your quick answer.

Haha,

I know it doesn’t help you now, but at least you know it will be added soon and it should only be a month or so too.

I think classes were added in 1.3.5 (1.3.6 was a hotfix) so basically the last major release so I would expect it to take a couple of releases for it to be fine-tuned and fully baked in :slight_smile:

No worries at all, I hope you have a great time using Bricks!

1 Like

Hi Joachim,

Welcome to the forum and thanks so much for your report, which has been already reported (here and here) and is already on our to-do list (together with some more improvements related to copy and paste) :slight_smile:

I can promise you that it won’t take until version 3.5 until this is possible :wink:

Best regards,
timmse

Hi @timmse,
I want to inform you that this problem is happening with export/import template as well.

it will import all structure and settings for every element but any class that has been added with its CSS won’t exist in the imported template.

Hi @q65,

welcome to the forum and thank you so much for your report!

You’re right, but this is another problem we’re already aware of :slight_smile:

Best regards,
timmse

1 Like