Bricks now with Unlimited Sites & Upcoming Lifetime Price Increase

WAIT: Woocommerce filter doesn't work

Bricks Version: 1.3.6
Browser: Edge
OS: win
URL: shop.chaosleague.org

Hey there,
i’m trying to use product filter, but it doesn’t filter anything. Anytime a click on taxonomy, it just reload the page. I’m doing something wrong or is a bug? Thanks for your support
Andrea

Hi Andrea,

you´ve limited the products query to some categories.
I’m not that deep into the Bricks + Woocommerce topic yet, but it seems like it would only work if the query is not limited.

I used your login credentials you´ve send to us via mail a few days ago and applied the changes: your filter is working now.

Best regards,
timmse

Hi Andrea,

just a quick info: we will check how to improve the filter in the future.
Until then, the solution I have already proposed works, but there is another (better) one.

Instead of using the product filter and products element, you can use the posts element, set the query to your products or product categories, activate the filter and filter them on the fly instead of reloading the page (as it it with the product filter). Works well with just a few products.

Best regards,
timmse

2 Likes

Hey @timmse thanks a lot for your suggestions. I want to share the solution that worked best for me.
I used th toggle element from bricksable to get the products shown by category. It’s pretty elegant :slight_smile:

1 Like

For me, it worked at first, but now is complete broken and doesn’t show at all. I can’t even delete a products block and insert one with default options. Apparently, this was a bug of the past that hasn’t been truly fixed.

Hi Anthony,

sorry to hear that! Is your problem related to the products filter or Bricks and Woocommerce in general? Maybe you can send us an email to help@bricksbuilder.io with temporary login credentials and a detailed description of where exactly your problem is.

Best regards,
timmse