WAIT: Styles not being rendered on front end

Bricks Version: 1.3.7

This is new, it has never happened before. Simply put, I am setting some properties of a container (to the ID, not a class): height 100vh, padding 20% 10% 0 10%, align-items=flex-start.

The canvas in the builder shows it as it should…all good there:

But on the front end, none of those properties are being applied:

They are NOT being overridden by a class…they are just not being written to the bricks page CSS file! Inspecting the DIV confirms this:

No properties (height 100vh, padding 20% 10% 0 10%, align-items=flex-start) there!

What’s even more bizarre is that even if I add the required CSS to the custom CSS fro the container, it does not appear on the front end either.

If you want to inspect the site, it’s https://pogo.infinitemonkeys.ca/ and the container with the problem is #bricks-element-pvopzu

There’s no caching set up on this site.

Update: it also occurs with version 1.3.6.

Another update:

The container has formatting now on the front end, but only because I’ve added external custom CSS a workaround for this bug.

However, the same issue of formatting not being applied to the front end while working in the build is also happening with elements INSIDE the container. Specifically, a Basic Text element that I added…styled it as color: #fff, font-weight: 700, looks fine in the builder:

But on the front end, that styling does not appear:

I will need to add a custom external CSS override to this as well.


The plot thickens. I’ve worked on this page for another 6 hours or so, and I tried removing my custom CSS styles, and lo and behold…it is now behaving as expected. So the site URL will be of no help now, but the screenshots above do provide a very real picture of a very strange problem.

1 Like

Hi Eric,

can you please provide login credentials again? Unfortunately, the login link from the beginning of January no longer works.

Best regards,

As it’s no longer occurring, a login won’t help you, will it? The only evidence I have is those screenshots above—but it clearly shows something weird was going on. I can share a login if/when it occurs again, and I’ll create a copy of the page next time so I can continue working without inadvertently “fixing” the issue so you can experience it and hopefully find the cause.

Hey Eric,

I believe you 100%, and I can see something strange has happened. But from the screenshots, we can’t understand what exactly went wrong because there can be too many potential causes. It’s like when you say to your car mechanic: my car made strange noises. But not anymore… do you understand what I mean?

Therefore, if the problem occurs again, I can only ask you to make a screen video (in the best case with an open developer console to see any js errors) and send us the access data (incl. problem description and video). Then we can check what is going on.

Sorry for the inconvenience!

Best regards,