WAIT: Popup bypasses maintenance mode

I came across some issues with the popup.

  1. It bypasses maintenance mode. See my test site: https://biet-mus.nl/

Interactions that I have tried, one by one:
Mouse leave window (with maintenance mode on, it shows on desktop, but not on mobile)
Content loaded - 5s delay (same)
Scroll + 95vh (maintenance mode on: does not show on desktop, but it does on mobile)

Conditions:
Individual
Page: home

Just wanted to report this, so a solution might be found.

For now, I am going to work around it on my official building site, by not showing the popup on the homepage.

  1. Setting scroll on 95vh - popup shows already on about 20vh.

I have tested it on another site, and will change this to content loaded + 5s delay, just to work around it. So I can’t show the example.

  1. Same setting as in 2.

Popup limit: set to 2.

But popup shows only once.

Hi Lydia,
Thanks so much for your report!

  1. The crucial question is what condition the popup has. Presumably, it is “entire website,” right? If so, it is understandable that it is also displayed in maintenance mode. However, this is not a bug but a suggestion for improvement like this one: [Maintenance] Can this template have above all priority please?

  2. Please provide a live link so I can examine the styles/setup and replicate the issue.

  3. Please provide a live link so I can examine the styles/setup and replicate the issue. Btw., the popup here is limited to “2” and works perfectly fine :thinking:

Best regards,
timmse

Hi timmse,

  1. The conditions are mentioned in my first post. It is for Biet&Mus: individual, home.

It is indeed a minor issue, but I still don’t think it is a good fit when a site is in maintenance, that a popup shows up.

  1. See my original post, I have worked around this by choosing a different interaction. It should be easy to replicate the issue on a test site.

  2. I have checked this morning on my official building site the setting:
    scroll on 95vh and popup limit set to two, and the popup showed only once.

Conditions: individual: home NL, and several other pages - each selected as individual.

I can’t give access to this site, as I really have to finish building.

I only wanted to report this as it is nice to strive for perfection, and thought the developers of Bricks might be interested in knowing these little things.

But I can work around it by choosing different settings for now.

Hi timmse,

Regarding issue 3: popup limit set to two, but showing up only once.

This is happening in Chrome browser.

But in Firefox it does show up twice.

I just found out. Isn’t that odd?

At least we now know that it is not related to Bricks!

Just wanted to post this update, in case others run into similar issues.

Lydia

  1. Ok, I see. However, it is still understandable that the popup is displayed on the homepage, as the homepage is called up when maintenance mode is active (the URL is the same, only the template changes).
  1. (&3) I can’t replicate it; that’s why I asked for a live link or, even better, access data (email to help@bricksbuilder.io). Please create a clone/staging of the website. Then, you can continue your work, and we can test in parallel to solve the problem if we can confirm a bug.

Hi timmse,

Thanks for your reply.

I am currently building my first site in Bricks.

So I need to practice a lot of things. For this I use a staging site. And then, when it is OK, I am implementing them on the real site.

So the staging site is refreshed many times a week or per day.

Once my site is finished, there is time to solve this little issue.

Lydia