WAIT: I lost all my global class

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Sent via email

Video: Short screen recording that illustrates this issue (free tools: birdeatsbug.com or jam.dev)

I updated my website to version 1.7 two days ago, and everything appeared to be in order. I checked my website this morning only to see that the design is messed up. When I opened the editor, I discovered that none of the classes I had created were present on the site. I have a backup, but before I roll it back, I need you to look at it for me. It’s urgent, please. Thank you

I have sent website URL and login details to bricks support @timmse @jornes please check and revert. Thank you

Hi Emamnuelson,
Thanks so much for your report!

I see that you are already in contact with Thomas by email, so this thread is actually superfluous :slight_smile:

It is sufficient if you either contact us by email or create a report here in the forum. Both at the same time only tie up resources unnecessarily.

Best regards,

Thank you for your response. Unfortunately, the issue I am facing is quite serious. After contacting one of your support persons, they confirmed that there is no global class in my database and there is no way to recover it.

I tried restoring a backup from before the update, but it also had the class lost. The only backup that had everything looking good was from Jan 22, but it didn’t contain almost 70% of the changes I made to the site after that backup.

I was wondering if there is any way I can retrieve the class from the Jan 22 backup to use on the latest backup from Feb 24. I would really appreciate any suggestions or solutions you may have.

Thank you for your help.

I lost mine today too. This problem completely changed my mind about Bricks.

Hey Aleš,
Welcome to the forum!

I see you are already in contact with Jenn via email, and he’s trying to track down the problem.

Best regards,

Any news on this? Did you guys had any other plugins installed except bricks?

@zestjosh helped recover mine. Check this thread. SOLVED: Bricks classes lost - #34 by zestjosh