WAIT: Gravity forms not showing in builder

Bricks Version: 1.5
Browser: Chrome
OS: Windows 11

Gravity forms are not showing up in editor - they do on front end.

Using Bricks 1.5, shortcode element.
I just get a blank block in the editor.

Tried to add it with max addons to check if that works - same result.

As said: it does show on the front end.
Any idea’s?

Just to add to this;
I already tried flicking the WP REST API switch, didn’t work.

Bricks Builder (Shortcode Element) does not render gravity form shortcode.

In browser console, I see jQuery Errors

1 Like

I resolve this issue
jQuery is not loaded in the bricks builder.
When I load WordPress jQuery on the gravity form page.
then my gravity form is working fine

1 Like

And how do you do that?

You can place this code in your functions.php of your child theme:

function load_jquery() {
  wp_enqueue_script( 'jquery' );
}

add_action( 'wp_enqueue_scripts', 'load_jquery' );

Thread:

using wordpress enqueue scripts functions

Please load jquery only on gravity form pages.

Ok, using a shortcode the GF is showing (progress :slight_smile: )

*edit… was too fast. On every change the canvas goes blank. Can’t work with it. :frowning: *

Bought Fluent Forms, and the issue isn’t there.
Just stays visible.

So can confirm the bug is related to Gravity Forms.

Go to Dashboard > Bricks > Custom code > Custom CSS

And add…

.brx-body.iframe .gform_wrapper {
   display: block!important;
}

(gravity forms is adding display: none inline when the page first loads, and then using JS to remove it, the JS just isn’t working in the builder)

1 Like

That seems to be it! Thanks a lot!!!

Would you happen to know a solution for this as well? (stacking of input fields instead of checkboxes / radio buttons showing inline) ?

I would have done the same as you have already suggested in that post, to just override the default label styling from Bricks and set to inline block.

1 Like

Good to hear - felt a bit like missing knowledge.
Thnx!