WAIT: Dynamic function for element conditions doesn't work

Browser: Chrome 110
OS: Windows
URL: Link to a page that illustrates this issue
Video: Here

Hi

I want to show/ hide the sidebar from a Single Page Template based on the post type. so for example I want to show the sidebar inside the Posts and hide it in other CPT’s Single Page as I am using the same Bricks Single Template for both post types.

You can have a better understanding about the bug from this video → Here

Thank you :sweat_smile:

Hi Baraa,
Thanks so much for your report!

I can’t replicate the issue, but as far as I can see, the sidebar content is there, but it’s set to display: none :thinking:

Please double check your display styles.

Best regards,
timmse

@timmse
I have hidden the other sidebar in order to focus on only one sidebar because if it worked, I would have shown a single sidebar in the programs CPT and hide the other one and vice versa for the Posts.

Have you attempted to apply the condition using the get_post_type function across various Custom Post Types and you still can’t replicate the bug?

Yes. I’m using the same template for two different post types (post and a CPT called movie), {echo:get_post_type()} returns the correct post type, and the condition works when comparing against “post” or “movie”.

If it really won’t work for you, please send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase so that we can take a closer look.