WAIT: Builder save wheel never stops, and never saves

Browser: Chrome 110
OS: macOS / Windows / Linux / etc.
URL: Link to a page that illustrates this issue
Video: Jam

[Please describe this bug in as much detail as possible so we can replicate & debug this bug]

System Information

Theme Information

Theme name: Bricks Child Theme
Theme version: 1.1
Theme author: Bricks
Theme author URI: https://bricksbuilder.io/
Theme is child theme:
Parent theme name: Bricks
Parent theme version: 1.9.6.1
Parent theme URI: https://bricksbuilder.io/
Parent theme author URI: https://bricksbuilder.io/

WordPress Environment

Home URL: https://www.kdpetrunina.com
REST API Prefix: wp-json
WP version: 6.2.4
WP debug:
WP language: en_US
WP multisite:
WP memory limit: 256 MB

Server Environment

Server info: LiteSpeed
MySQL version: 5.5.5
PHP version: 7.4.26
PHP post max size: 135M
PHP execution time limit: 180
PHP max input vars: 10000
PHP safe mode:
PHP memory limit: 512M
PHP max upload file size: 128M

Active Plugins

Admin Columns Pro (6.4.5) by AdminColumns.com
Automatic.css (2.8.1) by Kevin Geary, Matteo Greco
Frames (1.4.3) by Kevin Geary, Matteo Greco
HappyFiles Pro (1.8.3) by Codeer
Meta Box (5.9.3) by MetaBox.io
Meta Box AIO (1.24.2) by MetaBox.io
Regenerate Thumbnails Advanced (2.5.0) by ShortPixel
ShortPixel Image Optimizer (5.5.5) by ShortPixel - Convert WebP/AVIF & Optimize Images
Slim SEO (3.23.1) by eLightUp
Slim SEO Link Manager (1.8.0) by eLightUp
Slim SEO Schema (2.4.1) by eLightUp
White Label CMS (2.7.2) by www.videousermanuals.com
WPCodeBox 2 (1.0.3) by WPCodeBox

Additional notes: I searched for this issue before and found that some users had conflicts with Metabox Revisions, so I disabled that, but the issue persists.

Hi Michael,
Thanks so much for your report!

There is a critical error while saving:

Have you tried disabling all plugins and custom code?
Also, please take a look at your server logs. It will probably tell you what caused the problem.

Best regards,
timmse

1 Like

Disabled Metabox Revisions extension and it worked for some reason even though I tried that once already and it didn’t the first time. Zero clue what happened there, but here’s the PHP error from the log:

PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function MB_Revision::copy_fields_to_revision(), 1 passed in /wp-includes/class-wp-hook.php on line 308 and exactly 2 expected in /wp-content/plugins/meta-box-aio/vendor/meta-box/mb-revision/revision.php:47

Stack trace:

#0 /home/63dfef92c1ac235b04996a0b/public_html/wp-includes/class-wp-hook.php(308): MB_Revision->copy_fields_to_revision(1185)

#1 /home/63dfef92c1ac235b04996a0b/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(‘’, Array)

#2 /home/63dfef92c1ac235b04996a0b/public_html/wp-includes/plugin.php(517): WP_Hook->do_action(Array)

#3 /home/63dfef92c1ac235b04996a0b/public_html/wp-includes/revision.php(365): do_action(‘_wp_put_post_re…’, 1185)

#4 /home/63dfef92c1ac235b04996a0b/public_html/wp-includes/revision.php(191): _wp_put_post_revision(Array)

#5 /home/63dfef92c1ac235b04996a0b/public_html/wp-content/themes/bricks/includes/ajax.php(718): wp_save_post in /home/63dfef92c1ac235b04996a0b/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-revision/revision.php on line 47

Hi Michael,
The error messages point :100: to MetaBox. According to MetaBox support, the revision problem was already fixed at the beginning of february:

Since you still seem to be having problems, please contact MetaBox support.