Theme styles overwriting the single setting selection

Bricks Version: 1.3.2
Browser: Version 92.0.4515.107 (Official Build) (64 bit)
OS: Windows 10

Hi there, I’d like to report something that gave me some troubles. I added a post section in my homepage, and choosed white as field typography color of the title. It appeared right in the builder, but in the frontend it appeared of another color. I checked, and that color was coming from this CSS section:

.bricks-element-accordion .accordion-content-wrapper a, .bricks-element-icon-box .content-wrapper a, .bricks-element-post-content a, .bricks-element-posts .excerpt a, .bricks-element-shortcode a, .bricks-element-template a, .bricks-element-tabs .tab-content a, .bricks-element-team-members .team-member-description a, .bricks-element-testimonials .testimonial-content-wrapper a, .bricks-element-text a, .bricks-element-list a {color: #2196f3}

Judging from the comment above the css code, it appears that is taking that color from the theme style. I went and check, and I was right. I know this is what I selected (btw, I forgot this when tried to troubleshoot), but I suggest to put an option that overwrites the theme style selection when another setting is chosen in the builder, because (in my opinion) that’s the expected action when I go and change something from the builder, to overwrite the theme style, which is gonna apply where I’ve not selected anything. Let me know what you think and keep up the great work! :slight_smile:

Hi @giovannicastellotti ,

sorry but i can’t reproduce your problem. Which setting did you change in theme settings to make it work properly?

Sure. When you open the editor, on the upper left corner, I clicked the settings icon. Then I went to “Theme styles”, and there the “Link” section had the color set to that blue. When I tried to overwrite it in the settings of the post widget of bricks, the color changed as I wanted in the preview of the builder, but in the frontend it did not. Tomorrow I’ll send you a video. I don’t know if this is only a problem of my site.

Hi @giovannicastellotti,

still can’t reproduce the problem. The Theme Styles » Links Settings won’t affect my posts element at all. There seems to be a bug related to Theme styles » Links / Hover Styles - maybe this is also causing your problem.

I am looking forward to your video.

Hello @timmse, This is not exactly the bug you reported, but this video will help you understand. I actually don’t know if this is intentional, but in my opinion the change of the single setting should override the general settings. Let me know if I’m wrong.

This is the video:

P.S. as you can see I’m using an incognito window, so no cache problem within my browser. I don’t have any cache plugins on my site.

Hi @giovannicastellotti ,

thank you for the video! Hm… this is pretty strange, because like i said before, link style settings in theme styles won’t affect the post title links on my test installations (Bricks 1.3.2). I tried it twice, see:

Maybe it’s a chance to reset all theme styles (and also their hover styles) that may be related to links and headlines.

Good to know it is working as expected. Maybe it has to do with my site. Not a problem though. Now I know this and I can solve it.

1 Like