SOLVED: "Template" Element screws with alignment of saved section's contents

Bricks Version:
Browser: Chrome 103, Firefox
OS: Linux Mint 20.2
URL: (Issue can’t currently be seen there because I worked around it by adding margin: auto; to #brxe-jharma, you can see the issue by deactivating that rule in Inspector)

Steps to Reproduce:

  1. Create new page, click “+” to add new elements
  2. Select “Container” element using “Layout” button in top left
  3. Select first option, “Full Width (Section)”
  4. Build some stuff inside the section > container
  5. Save the whole thing as a template, selecting “Section” as type
  6. On another page, add the “Template” element at root level in the layout structure
  7. Select the template saved in step 6

Current Results:
The template’s content, even though centered when the template stands alone, floats left when added to a page layout at the layout structure’s root level.

Expected Results:
The template should behave the same way it does when viewed on its own, outside of a page context.

I think this has to do with the “Template” element wrapping the template in a div. That way, the template’s root element (the ) inherits a class, or at least some interfering CSS.

Template: Screenshot, 2022-07-18 21:07:57 - Paste.Pics
Template on a page: Screenshot, 2022-07-18 21:02:06 - Paste.Pics

Hi Matt,
Welcome to the forum, and thanks so much for your report!

The issue will be fixed in 1.5stable, as we already had a report about missing styles on the template element:

Best regards,

1 Like

That sounds splendid! Thanks!

Hey Stefan,

I was about to create a ticket, but not sure it is related to this. (Mine is a page template - Blog single, not a section) and I have an issue with this being applied on the frontend:

If it is different, let me know, and I will create a new ticket :slight_smile:

Hey Michael,
This is neither related nor a bug. align-self: center has always been there and keeps the container centered. Without that, the container would always align left (because that’s the default for a flexbox item).

Ah, Just on a rebuild and this element was not affected before, so maybe something else will ping you a PM so this thread remains clean :+1:

Hello @mr.matt.eastwood

We’ve provided a fix in Bricks 1.5 RC

In the meantime, we released 1.5RC2 which is now available for manual download from your account page.

If the fix isn’t working as expected, please let me know here.

Thank you!

1 Like

Fix confirmed in RC2. Thanks!

1 Like