[SOLVED] Shape divider broken

Bricks Version: 1.5.rc
Browser: Chrome 103
OS: macOS / Windows / Linux / etc.
URL: (a link to a page that illustrates the issue would be really helpful)

It seems that shape divider doesn’t work as expected in 1.5.rc version, I tried to apply in both Sections and Containers. It just shows a small shape on top. I tried to give it Hight and Width as well, but doesn’t work.


Thank you so much for reporting this issue, @Nima

Seems like it only happens to SVGs without a width & height attribute.

Just as a temporary fix: Does adding the following global custom CSS to your site fix the shape divider issue? And does it still allow you to define a custom divider width & height in the builder?

.bricks-shape-divider svg {
  height: 100% !important;
  width: 100% !important;

I tried that CSS in both global and on Section and neither worked and actually I see they are already in 100% width and height on those selector (looking at dev inspection) even without that CSS.
But, I could get it 100% work in the attached image below while testing on inspection mode.

I tried this CSS in global Bricks Custom settings and worked, also I could apply any custom height and width inside the builder.

.bricks-shape-svg {
height: 100% !important;
width: 100% !important;

1 Like

I confirm this type of problem. I was just opening a topic about it. Thanks for the temporary solution

I can confirm this problem too, even with plain vanilla triangle (standard of Bricks, no uploaded svg)

This is how it looks in correctly

This is how it looks in 1.5rc wrong

Hi Thomas,

This fix works for me in my case, and the builder controls are responsive.

Before adding the temp fix, I was getting a :not psuedo class adding a 1em to both height and width, and the height and width controls inside the builder were unresponsive.

Many thanks


The shape divider SVG dimension bug should have been fixed in the latest 1.5 RC2 :partying_face:

If anyone is still experiencing any issues, please let me know.


Thanks, I tested and confirm that it’s fixed now.

1 Like

ShapeDivider fixed with RC2 :slight_smile:

1 Like