SOLVED: Remote templates not working

Bricks Version: 1.3.4
Browser: Brave
OS: Windows / Linux /
URL: (a link to a page that illustrates the issue would be really helpful)

Created some templates on one system. Enabled remote templates and entered the url and a password in Bricks settings.
Tried to access the remote templates from a different Bricks site. Changed the settings to point at the above site. But when I create a new page and import a template - I see Remote Templates tab instead of the Community Templates tab … but it says No templates found.
Tried changing the url at both ends and the password, but no improvement.

Not used this before so maybe I am doing something wrong?

Seemed like a great way to create a personal template site to share my custom templates, perhaps easier than exporting/importing.
Could be improved by having a button on the import templates page to choose between Community and Remote to save having to keep going back to settings to change over. Assuming you can’t just have both tabs available at once?

Hello @alanj,

This is regular behavior. If you set the remote templates URL, it changes from Community to Remote. Did you click on the refresh button?

There is an idea on the Bricks Ideas board about it: Ideas – Bricks. Please upvote it!

Hi @luistinygod ,

Yes I have tried the refresh. I have read the Academy article. I have removed the passwords just in case. I have also tried various url values for the whitelist and remote urls as it was unclear exactly what is required here - full path or just the domain?

Always the same. On insert a template it says Remote Templates but no matches found.

Maybe I am asking the wrong question? When it says Templates I expected that this would be the various Header, footer, single templates etc that I created.

I think I have already voted for that idea, as it won’t let me vote now.

BTW Found another issue while testing this. The Autosave/Revisions panel barely works. It displays a list of revisions but I find I can’t click on them easily. If I click on one I want to restore it then takes about 1 minute before it decides to accept it and highlight the chosen revision. Of course by that time I’d clicked on other entries. So the current delay makes it unusable. This only happens when I have made a number of edits on a page ( deleting a whole stack of containers to get a clean page to test on ). Also only happens on one site.

Hi @alanj

Thank you for the clarifications.

You need to insert the site url, example: https://my.site.url/ .

Yes, it will show the templates of the remote Bricks installation.

Please send us one email to help@bricksbuilder.io with temporary login credentials to your both WP installations: the one that is serving the remote templates and the other where you want to see the remote templates.

Resources: Remote Templates – Bricks Academy

Email sent with access details.

Hello @alanj

Thank you for that. I just replied to you.

The issue was related with the whitelist URLs. Usually the URLs contain a trailing slash but Bricks was comparing against a URL without the trailing slash. This will be improved in the coming Bricks release.

Many thanks Luis. It is all working fine now.

I thought I’d tried all permutations of URL but obviously missed the key one! Sorry.

Cheers
Alan

1 Like