SOLVED: Post Meta looses formatting in Archive Template on the frontend (visible in the editor)

Browser: Firefox 111.0
OS: Windows 10 Pro
URL: Link to a page that illustrates this issue
Video: Archive template error 2023-03-16 10-27-59.mkv - pCloud

I’ve got two meta post fields that won’t use the template settings on category pages.

The settings work great in the page editor, and they work great on the posts archive page, but on both the category and terms archive pages, those two meta fields refuse to use the settings from the editor.

I don’t have any other archive templates, and the current template shows all the other elements of the template correctly.

On the category page, the class name (the brxe- one) of the post meta block element is the same as in the editor. However, in the post archive page, the last part of the class name is different.

The element on the post archive page doesn’t accept any changes to the settings either (it’s still got the old margin settings).

I’ve tried clearing the cache, and the browser cache, and clicking the “delete cache” button, but to no avail.

Any suggestions?

Hi Filip,
Thanks so much for your report!

Unfortunately, I cannot reproduce the issue with my archive template.
Would you be so kind as to send temporary login credentials and a link to this thread to using the email address you used during the purchase?

Best regards,

Mail sent, hope you can figure it out! :slight_smile:

Hi Fiilip,
Problem solved. I honestly don’t know where it went wrong, but I just inserted a new meta element, copied the styles of the element from the archive template, and pasted them on the new element.

Generally, you could also make it a little easier for yourself by giving the archive template an additional condition: Individual » Blog. This way it is automatically applied to the blog page and you only have to make changes in one place. Remember to delete the Bricks content from the blog page if you want to use the archive template there as well.

Best regards,