SOLVED: Bricks Builder does not start if the Autoptimize plugin is activated

Browser: Firefox for Linux Mint mint-001 - 1.0 123.0 (64-Bit)
OS: Linux Mint 21.1

Hello,

Unfortunately, today I discovered when I wanted to convert a setup from Oxygen Builder to Bricks Builder, where I used the Autoptimize caching plugin, that Bricks Builder didn’t want to start.

When I tested the plugins, I found that it worked again when Autoptimize was disabled.

Best regards
Matze202

Hi @Matze202

I can confirm the issue. We’ll provide a fix in the next release. In the mean-time you can either disable the plugin while editing with Bricks, or leave it active, but append the ao_noptimize=1 to the builder URL, or you can add the following code on line 12 (inside the “register” function) of the theme file /bricks/includes/compatibility.php:

// Autoptimize (disable in builder)
if ( bricks_is_builder() ) {
	add_filter( 'autoptimize_filter_noptimize', function() {
		return true;
	} );
}
2 Likes

Hi Thomas,

Thank you, I thought I would have to switch to another plugin.

Hi Matze,

We’ve fixed this issue in Bricks 1.9.7(.1), now available as a one-click update in your WordPress Dashboard.

Please take your time and read the changelog carefully as Bricks 1.9.7(.1) contains breaking changes that will make your Bricks website more secure.

Changelog: Bricks 1.9.7 Changelog – Bricks

Please let us know if you are still experiencing issues.

1 Like