SOLVED: ACF Repeater on CPT not pulling data

Bricks Version: 1.4RC
Browser: Chrome 90
OS: macOS / Windows / Linux / etc.
URL: (a link to a page that illustrates the issue would be really helpful)

The newly implemented ACF repeater isn’t working correctly on a CPT sigle page template. It works well on a normal page design.

The repeater field is visible on the dropdown field choice but isn’t displayed on the final page.

Ps. Apparently, it only works on pages. It won’t work on post nor any other CPT.

Hi Maru,
Thanks a lot for your report!

Can you please share a screencast showing and explaining your setup?

Best regards,


There is nothing special really. Just a simple gallery website with CPT UI and ACF.

I created a new CPT and added a page with a repeater to test how it works. Apparently within the selector, I can see that the repeater is selectable but do data is shown on the frontend.

Now if I do the same thing on a normal page instead of a post or CPT element, it is displayed correctly.

Hi Maru,
Thank you very much for your reply!

With custom fields it is sometimes difficult to find out what the problem is, so I asked you to show how you created your fields and used the repeater to rule out a mistake on your part (can happen :wink: ).

We could identify the problem in the meantime, so it will be fixed in the next version.

Best regards,

I will try to make one to reproduce the problem but on Facebook group, the problem seems to be replicable by other members.

As said before, We could identify the problem in the meantime, so it will be fixed in the next version.

1 Like

Was this issue solved in RC2?

Hi. I just tested and it seems like it has not been solved yet. I trust the team to solve it before the official release though.

Hello @Maru

Is it possible for you to send us one email to and share with us temporary login details so we could investigate what the issue is? Please mention this forum post and let us know what is the ACF Repeater field and on which page are you using it.

Thank you

Hello @omega

Yes, this was fixed in Bricks 1.4 RC2. If this is still not working for you let us know by sending us one email to mentioning this forum thread and if possible, with login credentials to your WordPress installation so we could check it.

Thank you.

1 Like

My bad. Yes after clearing out the cache, the new release seem to have solved the issue. Thank you.

1 Like

Hello @Maru

Thank you for the feedback.