SOLVED: [1.5 RC] RTL issues when selecting LTR as builder language direction

GREAT! Looking forward to the RC2

1 Like

Hey guys, the RC2 is now available for manual download from your account page :slight_smile:

Please let me know in case the solution isn’t working as expected.

1 Like

Will test it ASAP :slight_smile:

Hi @thomas,
It is working. Thanks. Now Canvas is RTL in both RTL and LTR Builder Directions!
I think we had left align and right align icons in rich text editor and it has been removed. It will be helpful for us to have them back in rich text editor. The reason is that rich text edior is obeying panel direction in the panel and obeying canvas direction in inline editing mode in canvas. So rich text edior is both rtl in canvas and ltr in panel but if we have align left and align right icons we can manage to make it rtl in the panel too, otherwise everything seems fine for now. Maybe if we will notice any issues in the future and will report them.
Regards,

1 Like

.brxe-nav-menu .bricks-nav-menu > li {
margin: 0 0 0 30px;
}
Nav Menu for English/LTR? I’m only facing this?

align left and right
I mean If we have these icons in rich text editor then we can manage to make it rtl in panel too. Actually I was wrong in my previous comment. They were not available in previous version too but I noticed that tinymce advanced plugin have added them. If we have them natively it will be better otherwise we can install tinymce advanced plugin to add them.
As far as our concern about canvas has been resolved. Adding these rtl and ltr icons will be a bonus.

1 Like

Mmm ya it is needed!
Have you tested the Nav menu? RTL/LTR???

What do you mean Kareem?
Menu direction is OK and I don’t see any problem.

No I just tested for RTL menu in RTL mode. What is the reason to test LTR menu in RTL mode?

LTR language nav menu > there is a margin by default!

this> LTR > English Menu:

this> RTL > Arabic Menu:

Okay. You should add css for it.
By default margin is added to left of li tags in LTR menu and to right of li tags in RTL menu and that is completely OK. If you want to add English words to your RTL menu then change margin by css.
I think there won’t be any solution by default that bricks detect if you have written Arabic it will add margin to right and if you have written English it will add margin to left. I think not possible. Bricks just detect the direction and according to direction it adds margin to li tags. It can not detect words in which language they have been written.

This is in LTR! English all >canvas/backend/frontend… language! Using Polylang!

The RTL/ language Arabic nave… working fine!
As in the SS above!

I think it will be better to open a new ticket for this issue othersiwse it will be lost here. I have not tried polylang and can not get it. Since this ticket has been marked as solved by admins, I recommend to open a new ticket. I think solved tickets are open for more conversations like this but will not be followed to resolve bugs.

Weird! You’re installing one language! I get it!
But this is related as well!
The nave menu preform as RTL on English/LTR lanauge! it’s not related to Polylang!
this is because I have a multilanguage website… which will happen to many!

I am using two languages and both of them are RTL so I do not need direction change but I need translation change. For translation change I use plugin load filter which has an option to select language per page or post. If I select Pashto language in a post then Wordpress will load Pashto language translation for it and if I select Dari(Persian) language in a post then Wordpress will load Dari(Persian) language translation. I think Plugin Load Filter can change direction too but I am not quite sure.

1 Like

OKAY! @thomas
So far everything working fine with LTR/RTL languages admin panels & canvas!
Except for 2 things…

1-Issue> First as for me, I’ve Polylang installed, RTL Arabic & English LTR!

The nave menu behaves as RTL alignment in both languages LTR English RTL as well! Backend/Frontend& Canvas.

2-Extra Tip, Can be helpful if added>

This is marked as resolved.
I’ve re-test it the Nav element again more than once to make sure it’s working fine… It is now :slight_smile:
The problem/alignment needed to just set it like this:
TOP Level Menu > Margin > 30PX Left > for RTL language.
TOP Level Menu > Margin > 30PX Right > for LTR language.

Thank you very much @thomas :smiling_face_with_three_hearts: