Problems with Post Content Data source Bricks

Hello,

1.)
I have set via Theme Styles that links have a 2px padding-bottom >> screenshot-modusx.de-2022.06.22-20_02_15 - Nimbus Capture.
Unfortunately, this is also applied to buttons >> screenshot-modusx.de-2022.06.22-20_02_44 - Nimbus Capture.
How can I exclude the buttons from this rule? They are not supposed to have a padding-bottom of 2px.

In the Bricks-Builder it looks correct >> screenshot-modusx.de-2022.06.22-20_07_28 - Nimbus Capture

2.)
I gave the buttons styles and also set up the hover effect.
Unfortunately, something completely different happens live. I think a different CSS is taking effect.
What should happen can be checked via the two hero buttons (try hover) >> https://modusx.de/
What happens can be checked here >> 2er Split: Oberkörper/Unterkörper Trainingsplan | modusX (screenshot-modusx.de-2022.06.22-20_02_44 - Nimbus Capture).

In the bricks builder the hover effect works as it should. Only live it does not fit.

3.)
I use a template and load the content via the Post Content element >> screenshot-modusx.de-2022.06.22-20_09_32 - Nimbus Capture.
As you can see on the image the display in the template is not correct at all. This is how it should look >> screenshot-modusx.de-2022.06.22-20_07_28 - Nimbus Capture

I think there is too much CSS loaded here and the styles are overwriting each other. How can I solve the problems?

Thanks in advance for your help :slight_smile:

1 Like

Hi,

It looks like all these issues are related to this bug: CSS links styling is too invasive - #7 by yankiara

Please insist so that they fully understand the scale of the issue (@timmse, @thomas), which is critical to me.

I use this fix for now in includes\theme-styles\controls\links.php file:

  • comment out line 8 ('.brxe-post-content a')
  • add ‘p a’ to properly style text links inside paragraphs

image

2 Likes