NO BUG: Cannot Save Pages Containing {echo:}

Browser: Safari Latest
OS: macOS

Edits containing “{echo:xxx}” anywhere on the page do not save. After clicking save, the “success” toast appears, but refreshing the page shows it did not actually save.

Regular dynamic tags work fine.

I have tried disabling all plugins and resetting the Bricks settings do default but to no avail.

It does not work on my Cloudways server nor offline Laravel environment.

It was working fine a couple of days ago, so not sure what the problem might be.

Hi,
Welcome to the forum!

Would you be so kind as to send temporary login credentials and a link to this thread to help@bricksbuilder.io using the email address you used during the purchase?

Best regards,
timmse

Sent the email, thank you.

Hi @binggumedia,

Thank you for sharing access,

To be able to utilize {echo:} tags you need to enable code execution, which are currently disabled on your site:

Strange, when I tested it yesterday, I tried it with both the toggle turned on (including the permission toggle) and off. It seems to be working again.

I think it would be useful to allow the “{echo:xxx}” text to be saved, but not execute.

Thanks.